Spørsmål og svar

Tilbake
PHP 7.x, hvordan fungerer det hos Domeneshop?

Dette punktet i våre spørsmål og svar inneholder informasjon beregnet på både ikke-tekniske og tekniske brukere og utviklere.

PHP 7.2 er standard for alle Webhotell Medium eller større som er opprettet fra slutten av mai 2018.

Vi tilbyr følgende PHP-versjoner:

  • 7.1 (støttes til høst 2019)
  • 7.2 (støttes til høst 2020)

Hvis du opplever problemer du mener skyldes våre innstillinger eller mangler på våre servere, sjekk først at du har programvare som takler PHP-versjonen du benytter, og at tipsene nedenfor ikke hjelper, før du eventuelt kontakter kundeservice.

Oversikt


Når kommer PHP 7.x i ordinær drift?

PHP 7 er i ordinær drift.

Hva besvarer dette SOS-punktet?

Denne siden forsøker å dekke en del av de tingene vi tror det vil være spørsmål om, eller som vi har fått spørsmål om. Vi oppdaterer denne løpende.

Hva er forskjellene mellom de gamle og de nye webserverne?

  • Operativsystemet på alle de nye webserverne er kjører Debian 9 Stretch, en oppdatering fra Debian 8 Jessie.

Hva er forskjellen mellom PHP 5.6 og PHP 7.x?

Det er ingen større forskjeller mellom de forskjellige PHP-versjonene hos Domeneshop. Se her for detaljert informasjon om endringer mellom de forskjellige versjonene:

PHP-konfigurasjonen for PHP 7.x er stort sett lik med 5.6. Vi gjør spesielt oppmerksom på følgende:

  • Hvis ditt CMS (f.eks. Drupal, Joomla!, WordPress) ikke er oppdatert på flere år, eller egen php.ini kan du få feilmelding om "mysql connection", "mysql driver", eller "mysqli driver". Dette er fordi programvaren ikke er kompatibel med PHP 7. Oppgrader til nåværende versjon.
  • Støtte for IonCube Loader kan aktiveres på kontrollpanelet for webhotellet. Det vil da ikke være mulig å bruke egen php.ini. Dette er å foretrekke fremfor å fortsette å bruke egne php.ini-filer og egne tillegg.
  • Zend Guard Loader er offisielt avviklet fra og med PHP 7.0.

Hva fungerer ikke på PHP 7.x-webserverne?

Det aller meste av programvare som kjører fint i PHP 5.6, vil også kjøre i PHP 7. Sjekk med din programvareleverandør dersom du er usikker på om din programvare støtter PHP 7.

Du kan få feilmelding om MySQL, "mysqli" e.l. hvis du har gammel php.ini, denne filen må i så tilfelle fjernes.

For egen kode, se PHP-dokumentasjonen for hvilke endringer som ikke er bakover-kompatible med PHP 7.0.

Dersom du bruker egne moduler eller utvidelser i PHP 5.6, så må disse sannsynligvis oppgraderes for å være kompatible med nyere PHP (7.x). Dette gjelder blant annet (med ikke utelukkende) IonCube Loader. Støtte for IonCube Loader skal helst aktiveres via kontrollpanelet for webhotellet.

Kan jeg bytte mellom de forskjellige PHP-versjonene?

Ja, du kan bytte mellom de forskjellige versjonene. Merk at det kan ta inntil 20 minutter før endringer i PHP-versjon blir utført.

Når vi annonserer at vi ikke lenger støtter en versjon, så vil det ikke lenger være mulig å velge den versjonen.

Kan jeg teste/bruke PHP 7 på shell.domeneshop.no/via SSH?

Ja. Du kan bruke php-shell.domeneshop.no. Denne shell-serveren tilbyr automatisk samme PHP-versjon som det du har valgt for ditt webhotell.

Hvor lenge vil dere støtte de forskjellige PHP-versjonene?

Vi kommer til å støtte de forskjellige versjonene omtrent så lenge PHP tilbyr sikkerhetsoppdateringer, men starter utfasing før sikkerhetsoppdateringene avsluttes.

Vi sluttet å støtte PHP 5.6 og PHP 7.0 12. desember 2018.

For øvrige versjoner, vennligst følg lenken, og planlegg oppgraderinger i god tid. Våre planer kan endres sammen med PHPs planer for sikkerhetsstøtte.

PHP-programmet mitt virker ikke, hva kan være galt?

Se Hvordan kan jeg se PHP-feil/debugge PHP-kode? for hjelp med feilsøking i PHP.

Bruker du Wordpress, aktiver feillogging som beskrevet over. I mange tilfeller vil feilmeldingene som dukker opp henvise til en Wordpress-plugin som skaper problemer. Denne utvidelsen kan deretter deaktiveres ved å slette eller endre navn på plugin-mappen via FTP. Se her for en nærmere forklaring på hvordan dette gjøres.

Kjente problemer etter oppgradering

Dersom du opplever problemer etter oppgradering, sjekk denne stikkordlisten for vanlige problemer og løsninger.

"Your PHP installation appears to be missing the MySQL extension which is required by WordPress."

Din WordPress er for gammel, oppgrader til nyeste versjon.

"Error establishing a database connection"

Slett gammel php.ini.

"The mysqli extension is missing"

Slett gammel php.ini.

Siden vises ikke/feilkode 500

Joomla!/WordPress: se vår korte veiledning i feilsøking av Joomla!- og WordPress-problemer
Annen PHP-programvare: se vår veiledning i generell PHP-feilsøking

Silverstripe fungerer ikke

Slett mappen silverstripe-cache på webhotellet ditt.

SMF fungerer ikke

Prøv PHP 7.1 istedenfor PHP 7.2. Planlegg utskifting av SMF med produkt som støtter PHP 7.2 og nyere.

Norske tegn vises som spørsmålstegn eller ikke i det hele tatt

default_charset er i PHP definert til UTF-8. Hvis du har innhold i Latin-1 (ISO 8859-1) eller andre gammeldagse tegnsett, så vises disse feil. Du kan enten konvertere innholdet til UTF-8, eller sette default_charset="" i .user.ini

Egen ErrorDocument fungerer ikke for PHP-filer, men fungerer for andre filer

Alle filnavn som slutter på .php håndteres av uWSGI, Apaches ErrorDocument vil aldri slå til for slike filer.

Perl fikk en sikkerhetsoppdatering (debian.org) som ikke tillater direkte require av filer uten å spesifisere path.

Bruk local::lib og andre nåværende Perl-mekanismer for å lage egne Perl-biblioteker, eller manipuler @INC direkte hvis du vet hvordan.

Hvordan bytter jeg PHP-versjon?

  1. Logg inn i kontrollpanelet på www.domeneshop.no
  2. Klikk på "Mine domener"
  3. Klikk på det aktuelle domenet
  4. Klikk på "Webhotell"-fanen på toppen av siden
  5. Klikk på "Se på/endre" på linjen med PHP
  6. Velg så ønsket PHP-versjon.
  7. Trykk på "Endre" for å lagre.

Merk at det kan ta inntil 20 minutter før endringen trer i kraft.

Se også:

Stikkord:  

Innholdsfortegnelse

© 2018 Domeneshop AS · Om oss · Vilkår · Personvern